Minimum Tech Requirement for VoiceThread

Browser

For the best experience, VoiceThread (VT) works optimally in:

  • Google Chrome

  • Mozilla Firefox

VT can be viewed in the following browsers, but if you attempt to record in them, it may not work because they do not support HTML5:

  • Safari

  • Microsoft Edge

VT does not work in Internet Explorer because the browser does not support HTML5.

For the latest requirements, visit VoiceThread Browser Requirements.

Mobile

VoiceThread has a free mobile application that can be found on the Google Play Store or iTunes. When you first access VT through the mobile application, you must log in with your Net ID in order to access your VT personal and course content. Please refer to the following Accessing VoiceThread Mobile Guide.

For more information and support for mobile app usage, visit VoiceThread Mobile App.

Last Updated:
Thursday, January 2, 2020